At this time this incident is resolved. If you or anyone on your team experiences issues, please email support@iqti.com
Posted Mar 16, 2026 - 22:16 EDT
Update
Testing has shown that Verizon is now correctly routing traffic.
Posted Mar 16, 2026 - 18:38 EDT
Update
We have noticed that this problem is persisting to users with Verizon and Optimum service at their locations. We will continue to monitor as our operations have returned to normal.
Posted Mar 16, 2026 - 17:41 EDT
Monitoring
firmware was updated on equipment. we will monitor the situation
Posted Mar 16, 2026 - 16:48 EDT
Identified
Datacenter team has identified issues, and have restarted effected equipment
Posted Mar 16, 2026 - 16:46 EDT
Update
Our datacenter team has been alerted to outage to QTICloud resources. We are working with them to isolate the issue and resolve all issues.