QTICloud Performance

Incident Report for QTICloud

Update

We are continuing to work on a fix for this issue.
Posted Aug 19, 2025 - 10:25 EDT

Identified

Another issue regarding bandwidth has been identified, and a resolution is being implemented
Posted Aug 19, 2025 - 10:17 EDT

Monitoring

We identified the issue and operations are quickly returning to normal. We'll continue to monitor
Posted Aug 19, 2025 - 08:33 EDT

Update

We are continuing to investigate this issue.
Posted Aug 19, 2025 - 07:48 EDT

Investigating

We are investigating an issue where some logins may be unavailable or performance of virtual desktops are not as expected
Posted Aug 19, 2025 - 07:47 EDT
This incident affects: QTICoud Datacenter ISP and QTICloud VPN.